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To create a custom list, proceed as follows:

m  Click the File tab on the ribbon, click Options near the bottom of the left pane, click Advanced
in the left pane of the Excel Options dialog box, scroll down, and, then in the bottom of the
General section, click the Edit Custom List button.

®  You will see the Custom Lists dialog box in Figure 25-12. Click in the Import List From Cells
box (near the bottom), select the range (G6:G13) containing the list, and then click Import. You
will see your list of cities join the collection of built-in custom lists on the left. Click OK to close
the Custom Lists dialog box, and then click OK to close the Excel Options dialog box.

Custom Lists ? X
Custom Lists
Custom lists: List entries:
NEW LIST Sao Paulo Add
Sun, Mon, Tue, Wed, Thu, Fri, Sat Shanghai
Sunday, Monday, Tuesday, Wedne New York City e
Jan, Feb, Mar, Apr, May, Jun, Jul, A Palo Alto =
January, February, March, April, M: Seattle
Charlotte, Raleigh, Greensboro, Wi Lagos
Yankees, Astros, Cubs, Dodgers London

Spears, Swift, Kayne, Per Sydney
Sao Paulo, Shanghai, New York Ci

Press Enter to separate list entries.

Import list from cells: $G$6:$G$13 +

OK Cancel

FIGURE 25-12 The custom list of cities has been created.

Now if you type Sao Paulo in any cell, hover over the square in the bottom-right corner of the cell,
and drag the cursor down, you will see the cities listed in the order Sao Paulo, Shanghai, and so on. If
you drag the cursor down far enough, the list will repeat. Of course, if you want to drag down copies of
Sao Paulo, just type Sao Paulo in two cells and then drag down the two cells.

Problems

1. Inthe Makeupsort.xlsx file, sort the sales data alphabetically by location, then by product type,
then by name, then by date of sale, and finally by units sold.

2. The Sortday.xlsx file contains hours worked on different days of the week. Sort the data so that
the Monday data is followed by the Tuesday data, and so on.

3. The Sorticons.xlsx file contains annual investment returns with an up arrow used to indicate
good years, a horizontal arrow used to indicate average years, and a red arrow used to indicate
bad years. Sort the data by the icons in the Stock column with the up arrows on top, followed by
the horizontal arrows, and then the red arrows.

4. The file named Makeupsortfont.xlsx contains our makeup data with certain dates shown in
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blue, red, or brown font. Sort the data so that the brown dates are on top, followed by the red
dates, and then the blue dates.
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Excel tables and table slicers

Questions answered in this chapter:

| have entered in a worksheet the number of units sold and the total revenue for each salesperson,
and | can easily compute the average price per unit for each salesperson. How can | create a nice
format that is automatically copied if | enter new data? Also, is there an easy way to automatically
copy my formulas when new data is added?

| have entered in my worksheet several years of natural gas prices, and | created a nice line chart
displaying the monthly variation in prices. Can | set things up so that when | add new gas price data,
my chart automatically updates?

For each sales transaction, | have the salesperson, date, product, location, and size of the
transaction. Can | easily summarize, for example, the total lipstick sales in the East made by Ashley
or Hallagan?

How do table slicers (added in Excel 2013) help us “slice and dice” data in an Excel table?
How can | easily refer to portions of a table in other parts of my workbook?

Do conditional formats automatically apply to new data added to a table?

When most of us use Microsoft Excel, we often enter new data. Then we manually update our formulas,
formats, and charts. What a drag! The Excel table capabilities make this drudgery a thing of the past.

Answers to this chapter’s questions

I have entered in a worksheet the number of units sold and the total revenue for each sales-
person, and | can easily compute the average price per unit for each salesperson. How can

I create a nice format that is automatically copied if | enter new data? Also, is there an easy
way to automatically copy my formulas when new data is added?

The file Tableexampletemp.xlsx in the Templates folder for this chapter (see Figure 26-1) contains

the units sold and revenue data for each of six salespersons. You know that new data will be added,
beginning in row 12. Also, in column H, you would like to calculate the average price (Units/Revenue)
earned by each salesperson. You would like to create an attractive format for the data and have the
formula for average price copied down automatically as new data is added.
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5 ;Name Units Revenue

6 |John 814 39886
7 |Adam 594 26136
8 |Dixie 528 13200
9 Tad 806 20956
10 |Erica 826 27258
11 :Gabrielle 779 28044

FIGURE 26-1 The data for creating a table.

Creating a table allows your analysis and formatting to be automatically updated when you add
data. Begin by selecting the current range of data (E5:G11), including the headers. Next, click Table on
the Insert tab of the ribbon, or press Ctrl+T. After selecting the My Table Has Headers check box (it
might be selected by default) and clicking OK, you will see that the table range (E5:G11) is formatted
beautifully. This formatting will continue automatically whenever new data is entered into the table.
When you are working in a table, many styles and options are available on the Design tab (see Figure
26-2). The Design tab is visible only when the active cell is within a table. You can select a formatting
style that will be applied as new data is added to the table.

[Table Name: [&2{Summarize with PivotTable _-_-? === V| Header Row [_] First Column /| Filter Button

> Total Row lastColumn | =--=Z ZEZZZZ ZZZoC TEECC
Insert  Export Refresh ==l ol
. | Banded Rows Banded Columns

Table1 B-fiRemove Duplicates
1} Resize Table G Convert to Range Slicer
Properties Tools External Table Data Table Style Options Table Styles

FIGURE 26-2 The table design options.

Note that the column headings have drop-down menu arrows, as you can see in Figure 26-3. These
arrows work as filters that can be used to sort or filter the table. (I discuss filtering in more detail later in
this chapter.)

E F G
5 [[ETTS - 5
6 |Iohn 814 39886
7 |Adam 594 26136
8 |Dixie 528 13200
9 |Tad 806 20956
10 (Erica 826 27258
11 |Gabrielle 779 28044

FIGURE 26-3 Column headings with drop-down menu arrows.
The cells in the selected table (excluding the headers) are given the name Tablel by default. |

changed the name to Sales in the Properties group on the Design tab. If you click the Formulas
tab and then click Name Manager (in the Defined Names group), you can see that range E6:G11 is
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named Sales. The beauty of this range concept (and the table) is that the range dynamically expands
to include new rows added to the bottom of the table and new columns added to the right of the table.
In Chapter 22, “The OFFSET function,” | used the OFFSET function to create a dynamic range, but table
capabilities make the creation of a dynamic range a snap.

Suppose that in D15 you want to compute the total revenue. Begin by typing =SUM(S. Excel then
offers you the option to automatically complete the entry with the table range Sales. | implemented
AutoComplete by double-clicking the range name. You can also implement AutoComplete by select-
ing Sales (by clicking it once or pressing the Down arrow key) and pressing the Tab key. Then, when
you see =SUM(Sales and type an opening bracket ( [ ), Formula AutoComplete offers the option to
complete the formula with column headings from the Sales table. You can complete your formula as
=SUM(Sales[Revenue]) and calculate the total revenue as $155,480, as you can see in Figure 26-4.
Later in this chapter, you will see an example of selecting the entries in the AutoComplete box that
begin with number signs (#).

B © D E F G
5 Name  Ellunits ElRevenue |2
6 John 814 39886
7 | Adam 594 26136
8 | Dixie 528 13200
9 Tad 806 20956
10 | Erica 826 27258
11| Gabrielle 779 28044,
12 |
13 |
14
15 |revenue 155480
16 | =SUM(Table1[Revenue])

FIGURE 26-4 The total revenue for the original data.

If new rows of data are added, the data in these rows is automatically accounted for in the formula.
To illustrate this idea, you can add new data in row 12: Amanda sold 400 units for $5,000, as shown in
Figure 26-5. Note that total revenue has increased by $5,000 to $160,480.

The formatting has been extended to row 12 as well, and the total revenue formula has been
updated to include Amanda’s data. Even if data is added within the table (instead of at the bottom),
everything will be updated in a consistent fashion.
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B E D E | F | G
5 Name Bl units EdlRevenue ||
6 John 814 39886
7| Adam 594 26136
8 Dixie 528 13200
9 Tad 806 20956
10 Erica 826 27258
11 Gabrielle 779 28044
12 Amanda 400 5000
13
14
15 |revenue 160480
16 =SUM(Tablel[Revenue])

FIGURE 26-5 New data is added to the table in row 12.

Now, suppose that you want to compute in column H the price per unit earned by each sales-
person. Simply type Unit Price in H5 as the column heading, and then in cell H6 type =Sales[. In
the AutoComplete list, double-click Revenue and type a closing bracket (3). The formula is now
=SALES[Revenue]. Type a slash (/), and use Formula AutoComplete to complete the formula as
=SALES[Revenue]/Sales[Units]. An amazing thing happens. Excel automatically copies the formula
down to the bottom of the table in cell H12, as shown in Figure 26-6. If you go to any cell in column H,
the formula appears as [@Revenue] /[@Units]. Of course, =[@Revenue]/[@Units] is a lot easier to
understand than =G6/F6. This formula can be interpreted as taking whatever is in the current row in the
Revenue column and dividing it by whatever is in the current row in the Units column.

| B | € | b E F G H
5 MW Revenue Rl Unit Price iy
6 John 814 39886 49
7 | Adam 594 26136 a4
8 Dixie 528 13200 25
9 Tad 806 20956 26
10 Erica 826 27258 33
T Gabrielle 779 28044 36
12 Amanda 400 5000 12.5)
13
14
15 revenue 160480
16 =SUM(Tahlel[Revenue])

FIGURE 26-6 Automatically copying the unit price formula.
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If you click anywhere in a table, the Table Tools Design tab appears on the ribbon and offers
choices (see Figure 26-2), including the following:

Change Table Name Can be used to rename a table. | changed the name from Tab1lel (the
default) to Sales. Found in the Properties group.

Resize Table Adds or subtracts rows and/or columns to the defined table range. Found in the
Properties group.

Remove Duplicates Removes rows that contain duplicates. For example, selecting only the

Name column in the Remove Duplicates dialog box ensures that a name will not occur more
than once. Checking both the Names and Units columns ensures that no rows in the table will
match both Name and Units, and so on. Found in the Tools group.

Convert to Range Converts the table range to normal cells and removes the table structure.
Found in the Tools group.

Header Row If selected, displays the header row. If cleared, the header row is not displayed.
Found in the Table Style Options group.

Total Row | discuss the Total Row later in this chapter.
First Column If selected, applies a special format to the first column of the table.
Last Column If selected, assigns a special format to the last column of the table.

Banded Rows |[f selected, gives the even-numbered rows in the table a different format than
odd-numbered rows.

Banded Columns If selected, gives odd-numbered columns in the table a format different
than even-numbered columns.

Table Styles Select from any of the table formats shown in this group. Of course, if the table
expands or contracts, the format will adjust appropriately.

I have entered in my worksheet several years of natural gas prices, and | created a nice line
chart displaying the monthly variation in prices. Can | set things up so that when | add new
gas price data, my chart automatically updates?

In the file named Gasprices507.xIsx, the worksheet Original contains natural gas prices per thousand
feet from July 2002 through December 2004 (see Figure 26-7). As | previously described, you can select
B5:C34 (containing months and prices) and press Ctrl+T to create a table from this range. Then you can
create a line graph to display this data by clicking Insert Line Or Area Chart in the Charts group on
the Insert tab and selecting the fourth type of line graph, Line With Markers. The line graph | created
is shown in Figure 26-8.
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